recherche v sous excel

Dans 'Informatique: assistance et conseils'

  1. frede60

    frede60 New Member

    Inscrit:
    1 Août 2005
    Messages:
    365
    J'aime reçus:
    0
    :pascompris;
    Bonjour,
    qui peut m'aider pour une recherche v ? Je ne sais plus à partir de "nommer les colonnes". Il s'agit d'une facture automatisée. J'ai bien fait mon classeur excel avec les feuilles "commande", articles, client. Après ... Au secours !!!!
     
  2. Gastoune

    Gastoune New Member

    Inscrit:
    21 Août 2005
    Messages:
    3 180
    J'aime reçus:
    0
    Il faut que tu te mette, par exemple, dans la colonne "article" tu insère ta fonction recherchev, puis tu réfère à ce que tu cherche (le code article dans la colonne d'a coté), puis ou tu cherche ces valeurs (dans ton claseur article en indiquant la plage), puis le n° de colonne avec lequel il faut compléter.

    Ce qui te donne recherchev(A2;articles!A1:H6;2)....

    Je ne suis pas sure que ca soit tres clair......

    Bon courage :wink2:
     
  3. vestale974

    vestale974 Active Member

    Inscrit:
    16 Août 2005
    Messages:
    3 345
    J'aime reçus:
    0
    Salut,
    C'est assez simple, il suffit d'utiliser l'assistant de fonctions d'Excel (Cat : Recherche et Matrice)
    Je suppose que tu souhaites insérer cette fonction dans la zone "entête" et "détail" de ton modèle de facture/commande
    (NonCli, AdsCli, ..., Désignation, PUHT, etc.)
    Cellule A20 = Code Art
    Cellule B20 = DésignArt
    Etc.
    B20 = SI(ESTVIDE(A20);0;RECHERCHEV(A20;TABLE ARTICLE;2)
    où:
    ESTVIDE() traite le message d'erreur (#N/A!) renvoyé par la fonction RECHERCHEV() quand la cellule A20 est vide,
    A20 saisie ou sélection du code article,
    TABLE ARTICLE est le tableau contenant l'ensemble des valeurs de la première à la dernière colonne,
    2 est la référence colonne dans ta TABLE ARTICLE dont tu souhaites extraire la valeur.
    (1 = CodeArt, 2 = DésignArt, etc.)
    NB:
    Dans ce genre de travail, je conseille toujours à mes élèves d'utiliser des listes de choix pour la cellule CodeCli et la plage de cellules CodeArt, ceci pour éviter de saisir un code erroné.
    Dans chacunes de tables CLIENT, ARTICLE, etc, il faut impérativement nommer les plages de cellules respectives CodeCli et CodeArt, dans ton exemple, puisque ces tables sont a priori sur des feuilles de calculs de ton classeur.
    Ensuite sélectionner respectivement, étape par étape, la cellule CodeCli et la plage de cellules CodeArt, Aller dans le menu "Données", puis la commande "Validation". Dans les "Options", sélectionner "Liste" et affecter la source (nom des plages de cellules CodeCli, CodeArt)
    @+
     
  4. frede60

    frede60 New Member

    Inscrit:
    1 Août 2005
    Messages:
    365
    J'aime reçus:
    0
    :kiss:Bien reçu, bien compris !!!

    Merci pour toutes ces réponses. C'était urgent et j'ai pu faire le devoir à temps. Vive cultureco!!!
     
  5. Gastoune

    Gastoune New Member

    Inscrit:
    21 Août 2005
    Messages:
    3 180
    J'aime reçus:
    0

    Respect......propre, net et sans bavures.....
    et bonjour Vestal..... :wink2:

    C'était bien plus clair que mes explications :embarassed:
     
  6. vestale974

    vestale974 Active Member

    Inscrit:
    16 Août 2005
    Messages:
    3 345
    J'aime reçus:
    0
    :biggrin:
    Je suis tel Obelix, un jour et il y a fort longtemps, je suis tombé dans la marmite.
    :wink2:
     
  7. happy

    happy New Member

    Inscrit:
    13 Janvier 2006
    Messages:
    553
    J'aime reçus:
    0
    problème recherche v

    Voila en fait j'ai un soucis je fais une Recherche V et je voulais savoir si on pouvait mettre 2 valeurs_recherchées ? Si oui quel est le mot de liaison ou le signe de liaison qu'il faut mettre :
    =RECHERCHEV(B17 et F17;Catalogue!A4:C47;3;0) ???
     
  8. patrice084

    patrice084 Best Member

    Inscrit:
    12 Août 2005
    Messages:
    17 756
    J'aime reçus:
    2
    problème recherche v

    Non, une recherche cherche dans une table en fonction d'une valeur. Dans ce cas, il faut alors faire une formule conditionnelle. Sinon, détaillez plus votre souci, il existe peut-être une autre solution que la rechercheV
     
  9. happy

    happy New Member

    Inscrit:
    13 Janvier 2006
    Messages:
    553
    J'aime reçus:
    0
    problème recherche v

    Bah non l'exo demande la recherche V je crois que j'ai voulu me compliquer ou l'exo est compliqué bref j'ai envoyé mon cas j'attends la correction pour voir comment ils ont fait mais bon c'était vraiment complexe parce qu'apres il fallait envoyé sur access la table mais y avait un soucis alors soit l'exo est mal fait soit c'est moi
    merci quand meme patrice :)
     
  10. olilie

    olilie New Member

    Inscrit:
    4 Avril 2005
    Messages:
    1 183
    J'aime reçus:
    0
    est ce que tu peux m'expliquer a quoi sa sert la recherche V ? parce que je sais pas trop comment expliquer merci :unsure:
     
  11. vestale974

    vestale974 Active Member

    Inscrit:
    16 Août 2005
    Messages:
    3 345
    J'aime reçus:
    0
    Salut,
    La fct RECHERCHEV() se substitue à la fct SI() en raison du nombre limité d'imbrication. En effet, on ne peut imbriquer successivement que 7 fct SI() au maximum. En clair, si on a plus de 8 états à vérifier (test logique), la fct SI() devient inopérante.
    @+
     

Partager cette page