RechercheV Excel pour BDD??

joulesky

New Member
Bonjour,

Une ptite question que je n'arrive pas à résoudre...
J'ai une base de données clients sur Excel (code client - Nom du client - Adresse - Ville) et j'aimerai sur un autre fichier excel en rentrant juste le code client, que tout le reste s'affiche... :pascompris;

Faut il faire plutôt une recherche V ou y-a-t'il un autre moyen??
Merci pour votre aide :cool:
 

patrice084

Best Member
joulesky link=topic=98078.msg1101714#msg1101714 date=1241463283 a dit:
Faut il faire plutôt une recherche V ou y-a-t'il un autre moyen??

Oui, c'est une rechercheV et pas d'autre moyen plus simple que l'utilisation d'une fonction de recherche.
 

joulesky

New Member
Merci mais je n'arrive pas à faire ce que je veux... :mellow:

Feuille 1

A B
1 100 (Code)
2 Client
3 Adresse
4 CP Ville



J'ai une deuxième feuille nommée "Clients" avec ma base de données...

A B C D E
1 Code Client Adresse CP Ville
2 100 XXX Rue Y 75000 Paris



Donc, pour que le nom de mon client s'affiche en cellule B2 =(RechercheV(B1;CLIENTS!$B$2:$B$5;2;0)
Est ce que la formule est bonne??? J'en ai pas la moindre idée...

Je ne sais pas si c'est très clair, en tout cas merci pour votre aide... :cool:
 

vestale974

Active Member
joulesky link=topic=98078.msg1101789#msg1101789 date=1241509535 a dit:
Donc, pour que le nom de mon client s'affiche en cellule B2 =(RechercheV(B1;CLIENTS!$B$2:$B$5;2;0)
Salut,
Simple question ! Ta liste de données est bien située sur un classeur et l'extraction que tu souhaites en faire se fait à partir d'un autre classeur. objet de ton premier post (... j'aimerai dans un autre fichier...)!

Classeur source fermé
=RECHERCHEV(B1;'C:Documents and SettingsMonUserMes documents[NomDuClasseurSource.xls]Feuil1'!$A$1:$E$2;2)

Classeur source ouvert
=RECHERCHEV(B1;[NomDuClasseurSource.xls]Feuil1!$A$1:$E$2;2)
img
@+
 

joulesky

New Member
Je suis désolée, je dois être un boulet, vraiment je n'y arrive pas... :wacko:
Ci-joint une impression écran de mon fichier excel. http://cjoint.com/?fhfYY5OVUv
Il y a en fait 1 seul fichier excel avec deux feuille à l'intérieur mais je ne pense pas que ce soit vraiment ça le problème...

Merci pour votre patience... :aplause:
 

patrice084

Best Member
joulesky link=topic=98078.msg1101878#msg1101878 date=1241532725 a dit:
Je suis désolée, je dois être un boulet, vraiment je n'y arrive pas... :wacko:

Bizarre que le nom de la première feuille apparaisse. Essayer avec juste
=rechercheV(B1;'BDD Clients'!A1:E3;2)
 

vestale974

Active Member
Salut,
Et pourtant ça devrait marcher.
Il faudrait peut être envoyer ton ou tes classeurs ici
Histoire de comprendre pourquoi cela ne fonctionne pas
@+
 

Ca peut vous intéresser