Excel Formule SI

#1
Bonjour,
Voilà j'ai un tableau à faire avec cet énoncé:

Dans une colonne on a des montants
Si le montant est supérieur a 760 euros, alors on offre une remise de 5 %
Si le montant est entre 450 et 760 euros, on offre une remise de 3 %
Si le montant est inférieur à 450 euros on a rien

Je sais que la formule Si doit être imbriqué l'une dans l'autre mais le soucis c'est que les 2 formules a la fois ne marche pas

Par exemple quand je met si(B1>760;5%;"")+si(760<B1>450;3%;""), ca ne marche pas
J'ai essayé plusieurs type de forules mais rien ne marche
Si je mets seulement la première formule, je n'ai pas de soucis mais comment inserer la seconde ?
 

Fouinie

Best Member
#2
Sarah44300 link=topic=104837.msg1184650#msg1184650 date=1267802847 a dit:
Bonjour,
Voilà j'ai un tableau à faire avec cet énoncé:

Dans une colonne on a des montants
Si le montant est supérieur a 760 euros, alors on offre une remise de 5 %
Si le montant est entre 450 et 760 euros, on offre une remise de 3 %
Si le montant est inférieur à 450 euros on a rien

Je sais que la formule Si doit être imbriqué l'une dans l'autre mais le soucis c'est que les 2 formules a la fois ne marche pas

Par exemple quand je met si(B1>760;5%;"")+si(760<B1>450;3%;""), ca ne marche pas
J'ai essayé plusieurs type de forules mais rien ne marche
Si je mets seulement la première formule, je n'ai pas de soucis mais comment inserer la seconde ?
Envoi ton tableau, parce que c'est pas évident d'expliquer sans avoir les mêmes données...
 

vestale974

Active Member
#3
Sarah44300 link=topic=104837.msg1184650#msg1184650 date=1267802847 a dit:
...
Par exemple quand je met si(B1>760;5%;"")+si(760<B1>450;3%;""), ca ne marche pas
Normal, puisqu'en l'état votre formulation va additionner le résultat de vos 2 fonction SI(). C'est le signe + et sa position qui pose problème.

Vous devez construire votre fonction de la façon suivante :
Si la valeur de B1 est strictement supérieur à 760
Alors la remise est égale à 5%
Sinon
Si la valeur de B1 est strictement supérieur à 450
Alors la remise est égale à 3%
Sinon la remise est égale à 0%
Fin.Si

Fin.si.

=SI(Test_logique ; Valeur_Si_Vrai ; SI(Test_logique ; Valeur_Si_Vrai ; valeur_Si_Faux)).

=SI(B1>760;0,05; SI(B1>450;0,03;0)).
@+
 

Ca peut vous intéresser