RECHERCHEV

#1
Salut à tous

Je suis actuellement en stage et je travail sur une base de données excel. J'ai du créer une facture type qui reservira à ma tutrice.
Le problème c'est que au moment ou je veux faire ma recherchev pour mon numéro client cela ne fonctionne pas. :tickedoff: J'ai essayé de résoudre le problème avec elle, avec des amis mais personne ne comprend. J'ai vraiment besoin de votre aide.

Est il possible que ce problème soit dut au fait que je n'ai pas encore rentré mes numéros de client dans ma base de données, où tout simplement parce que ma formule est fausse ?

Merci de votre aide
 
#3
lol non je n'y arrive pas ...

Ma formule est:
=SI(B23="";"";RECHERCHEV(B23;Feuil1!A2:T301;15;FAUX))

et voila le message que je reçois: #N/A :wacko:
 
#4
reveuse link=topic=92512.msg1059547#msg1059547 date=1228207531 a dit:
Ma formule est:
=SI(B23="";"";RECHERCHEV(B23;Feuil1!A2:T301;15;FAUX))

=SI(ESTNA(RECHERCHEV(B23;Feuil1!A$2:T$301;15));"";RECHERCHEV(B23;Feuil1!A$2:T$301;15))

Question. Pourquoi la valeur Faux dans l'argument Valeur proche de la fonction RECHERCHEV() ? Est-ce justifié ?
Mais, ne pourrais-tu pas faire une capture d'écran voire joindre un PJ ton classeur, histoire de s'assurer qu'il n'y a pas une autre coquille dans ton tableau ?
 
#5
Merci de votre aide. J'ai réussi à me débrouillé, il me manquait juste les numéros client dans la base de données.

Maintenant je suis confronté à un nouveau problème ( je ne suis pas très bonne avec excel :wacko:)
Est-ce possible de mettre plusieurs recherchev dans une seule cellule ? Je vous explique, en faite je voudrais faire une recherchev qui me permettrai d'avoir civilité, nom et prénom dans la même cellule.

J'ai cherché un peu partout, dans mes livres et sur internet mais je ne trouve pas la solution. :embarassed:
 
#6
reveuse link=topic=92512.msg1062404#msg1062404 date=1228726396 a dit:
Est-ce possible de mettre plusieurs recherchev dans une seule cellule ? Je vous explique, en faite je voudrais faire une recherchev qui me permettrai d'avoir civilité, nom et prénom dans la même cellule.
Oui, il faut utiliser la concaténation.
=concatener(rechercheV(code;client;2);" ";rechercheV(code;client;3);" ";"rechercheV(code;client;4))
 
#7
Ca ne marche pas, je commence à devenir folle, voila 2 heures que je suis dessus ...

J'ai utilisé cette formule:
CONCATENER(RECHERCHEV(B23;carnet_adresse!A1:T303;2;FAUX));"";"";(RECHERCHEV(B23;carnet_adresse!A1:T304;3;faux));"";"";
(RECHERCHEV(B23;carnet_adresse!A1:T304;4;faux)) et le logiciel m'informe qu'il y a encore une erreur ...

Besoin d'aide !!
 

Ca peut vous intéresser